Contact Form gem for Rails4 and Rails3.2

Contact Form gem for Rails4 and Rails3.2

Today I had time to update my existing gem called contact_form, which is available on github.

It is now available for rails 4 and rails 3.2. Simple check out the old blogpost about this gem or the readme on github.

Feel free to open issuses or make a pull request, if something does not work the way you want.

UPDATE (10.09.2014):
The gem is now also compatible with rails 4.1.x

Matthias Frick
Ruby on Rails
4 Kommentare

Über den Autor

Matthias Frick
Matthias Frick, MSc.

Er ist ein langjähriger Ruby-on-Rails Entwickler und leitet das Unternehmen Frick-Web.

4 Kommentare zu "Contact Form gem for Rails4 and Rails3.2"

  1. Andrew Murpheys
    Andrew Murpheys 02.01.2014
    Thanks for sharing! Very nice gem.
  2. Jeroen Smit
    Jeroen Smit 09.09.2014
    Hi Matthias! Thanks for your gem. I'd like to use it with Rails 4.1.1. Running "bundle install" I get an error saying the following: could not find compatible versions for gem "rails": In Gemfile: contact_form (>= 0) ruby depends on rails (~> 3.2.8) ruby rails (4.1.1) Is it correct that contact_form doesn't work with Rails 4.1.1? Kind regards, Jeroen
  3. Matthias Frick
    Matthias Frick 09.09.2014
    Hi Jeroen! Yes the gem dependencies must be updated for newer rails versions. You can create a pull request or wait until tomorrow. I will update the gem. Best regards, Matthias
  4. Matthias Frick
    Matthias Frick 10.09.2014
    Hi Jeroen! I updated the contact-form gem right now for rails 4.1.x. It is available on rubygems or directly from github. Just checkout the README and let me know if you have further problems. Best regards, Matthias

Kommentar verfassen